CCNP Route 642-902 Implementing Cisco IP Routing

includes everything you will need to fully prepare for your CCNP Route certification
4.7 (253 ratings) Instead of using a simple lifetime average, Udemy calculates a
course's star rating by considering a number of different factors
such as the number of ratings, the age of ratings, and the
likelihood of fraudulent ratings.
8,528 students enrolled
Free
Start Learning Now
  • Lectures 86
  • Contents Video: 24.5 hours
  • Skill Level All Levels
  • Languages English
  • Includes Lifetime access
    30 day money back guarantee!
    Available on iOS and Android
    Certificate of Completion
Wishlisted Wishlist

How taking a course works

Discover

Find online courses made by experts from around the world.

Learn

Take your courses with you and learn anywhere, anytime.

Master

Learn and practice real-world skills and achieve your goals.

About This Course

Published 1/2014 English

Course Description

Cisco Certified Network Professional (CCNP) validates the ability to plan, implement, verify and troubleshoot local and wide-area enterprise networks.

who are ready to advance their skills and work independently on complex network solutions.

Those who achieve CCNP have demonstrated the skills required in enterprise roles such as

  • –network technician,
  • – support engineer,
  • –systems engineer or network engineer.

CCNP focuses on the skills needed by a network engineer working for an Enterprise

What are the requirements?

  • good understanding of Cisco CCNA Routing and Switching certification

What am I going to get from this course?

  • Upon completing this course, you will be able to meet these objectives:
  • Plan routing services to meet requirements
  • Implement an EIGRP-based solution
  • Implement a scalable multiarea network OSPF-based solution
  • Implement an IPv4-based redistribution solution
  • Implement path control
  • Implement and verify a Layer 3 solution using BGP to connect an enterprise network to an ISP

What is the target audience?

  • anyone wanting to prepare for the ROUTE 642-902 exam.
  • students who want to build on their CCNA level skill set to further a career in computer networking.
  • experienced networking professionals who are ready to advance their core routing, switching, and network troubleshooting skills and students with Cisco CCNA-level knowledge

What you get with this course?

Not for you? No problem.
30 day money back guarantee.

Forever yours.
Lifetime access.

Learn on the go.
Desktop, iOS and Android.

Get rewarded.
Certificate of completion.

Curriculum

Section 1: Introduction
Introduction to CCNP Certifications
09:12
How to access this Course on udemy
09:18
23:55

About GNS3 Simulation Tool

    ·GNS3 is an open source software that simulate complex networks while being as close as possible to the way real networks perform. All of this without having dedicated network hardware such as routers and switches.

    ·GNS3 is an excellent alternative or complementary tool to real labs for network engineers, administrators and people studying for certifications such as Cisco CCNA, CCNP and CCIE as well as Juniper JNCIA, JNCIS and JNCIE. Open source networking is supported too!

    ·It can also be used to experiment with features or to check configurations that need to be deployed later on real devices.

    ·To use GNS3 you first need to provide your own copy of a network operating system, like Cisco IOS, PIX, ASA, IPS or Juniper JunOS.

    ·You can download GNS3 software from http://www.gns3.net/download/

27:02

    ·To use GNS3 you first need to provide your own copy of a network operating system, like Cisco IOS, PIX, ASA, IPS or Juniper JunOS.

    ·You can download GNS3 software from http://www.gns3.net/download/

Section 2: Summarization
15:30
  • It is the process of combining smaller networks in to single large sub network (Combining the contagious address into one and send to neighbor.)
  • It helps in reducing the size of routing table.

Advantages

    ·Minimizing the routing table.

    ·Less use of resources like memory, processor, bandwidth.

10:06

Two Type of Summarization

·Auto summary

·Manual summary

AUTO SUMMARY

·Summarization is done to a default class full boundary

§A /8

§B /16

§C /24

·Class full routing protocol does auto summary by default and it can’t be disabled

·Routing protocol like RIPv2, EIGRP, BGPv4 support auto summary and can be disabled

·Routing protocol like OSPF and ISIS doesn’t support auto summary

Disadvantages of Auto-summary:

·Can create Problems if the network is in discontiguous Subnets.

·Not always applicable

To enable or disable auto summary

Router(config-router)# [no] auto-summary

Manual summary

·Administrator manually configures Summarization

·It is supported by all classless routing protocols

10:13

EXAMPLE – 1

SUMMARIZE THE FOLLOWING ADDRESSES TO NEAREST SUBNET MASK POSSIBLE

10.1.0.0/24

10.1.2.0/24

10.1.3.0/24

10.1.4.0/24

10.1.5.0/24

10.1.6.0/24

STEPS FOR CALCULATING MANUAL SUMMARY :

1)WRITE THE BINARY OF FIRST and the last number

2)Separate the portions in to two parts ( common and un-common) ( 0 – 0 or 1- 1 are common)

3) Convert right side values of the first number in to zeros ( change in to decimal) and leftside values should be same.

4) count the left side bits (to find the / value)

SOME EXAMPLES TO UNDERSTAND METHOD OF CONVERTING TO BINARY

128 64 32 16 8 4 2 1

6 0 0 0 0 0 1 1 0

25 0 0 0 1 1 0 0 1

29 0 0 0 1 1 1 0 1

1 0 0 0 0 0 0 0 1

1)Write the binary of first and the last number

2)Separate the portions in to two parts ( common and un-common) ( 0 – 0 or 1- 1 are common)

10.1.0.0/24 written as 10. 1. 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0

10.1.6.0/24 written as 10. 1. 0 0 0 0 01 1 0 0 0 0 0 0 0 0 0

3)Convert right side values of the first number in to zeros ( change in to decimal)

10. 1. 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0

Change the above binary value in to decimal to get network ID of summary address

10.1.0.0

4)Count the left side bits (to find the / value)

10. 1. 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0

8 bits 8 bits 5 bits 0 bits

From the above /value will be /21

So the final summarization address with nearest subnet mask possible is 10.1.0.0 /21

Manual Summarization Calculation Process exxample-2
11:17
Lab : EIGRP Summarization
24:09
Lab : EIGRP Summarization Advance
28:24
Section 3: EIGRP
19:02

In this Video you get Introduced to EIGRP from basics

06:04

Verifying the EIGRP Process discussed in the previous video using some of the debug commands

23:20
  • Metric (32 bit) : Composite Metric (BW + Delay + load + MTU + reliability )
15:01

CONFIGURING EIGRP FOR IP

Router(config)# router EIGRP

Router(config-router)#network network-id [wildcard-mask]

13:08
  • Feasible Distance
  • Total cost from local router to destination
  • cost from local router = AD of next-hop router + cost between the local router and the next-hop router
  • Advertise Distance
  • Cost from the next-hop router to the destination
  • 16:32

    FD of current successor route > AD of feasible successor

    Feasible Successor= Second best AD < FD of Successor

    Feasibility Condition part 2
    14:20
    22:14

    EIGRP supports both

      1.equal-cost load balancing

      2.unequal-cost load balancing

      ·Routes with lowest equal metric are installed in the routing table by default

      ·When a router learns a same route from different neighbors with the same metric it install both the routes in the routing table and does load balancing, this is called equal cost load balancing.

      ·Note:- It does equal cost load balancing automatically. whereas unequal cost is not automatic.

      ·For unequal cost load balancing we need to enable "variance"

      ·EIGRP can load share up to six paths. (The default is four paths)

    24:53

    EIGRP Unequal-Cost Load Balancing Allows the router to include routes with a metric smaller than the multiplier value times the metric of successor

      ·Variance is configured for unequal cost load balancing

      ·Variance is the multiplier to FD of successor

      ·Default is 1(equal cost load balancing)

    Router(config)# router eigrp 100

    Router(config-router)# variance

    13:32

    EIGRP STUB

    • Stub routingis one way to limit queries. A stub router is one that is connected to no more than two neighbors and should never be a transit router.
    • The EIGRP stub routing feature improves network stability, reduces resource utilization, and simplifies remote router (spoke) configuration.
    • Stub routing is commonly used in a hub-and-spoke topology.
    • A stub router sends a special peer information packet to all neighboring routers to report its status as a stub router.
    • A neighbor that receives a packet informing it of the stub status does not query the stub router for any routes.
    24:49

    Configuring EIGRP Stub

    Router(config-router)# EIGRP stub [receive-only|connected|static|summary]

    ·receive-only: Prevents the stub from sending any type of route.

    ·connected: Permits stub to send connected routes
    (may still need to redistribute).

    ·static: Permits stub to send static routes
    (must still redistribute).

    ·summary: Permits stub to send summary routes.

    Default is connected and summary.

    Section 4: Default Routes with Dynamic Routing
    14:06

    IN this video I explained why we need to inject default route in to IGP protocols

    25:29

    IN this video I explained how to inject default route in to EIGRP

    09:12

    IN this video I explained how to inject default route in to RIPv2

    09:03

    IN this video I explained how to inject default route in to OSPF

    Section 5: Basic OSPF
    25:55

    In this lecture you will understand the basic Process of OSPF 7 stages when you configure OSPF for the first time

    12:40

    In this Lecture we will discuss on the concept of Areas in OSPF and how to design some big complex networks using OSPF areas

    LAB: OSPF Single Area
    14:09
    LAB: OSPF Multiple Area
    09:06
    Section 6: Redistribution
    26:05

    Redistribution

    The process of exchanging routing information between different routing protocols

    When we use multiple protocol

    • Application-specific protocols

    • Mismatch between devices (Vendors)

    • Political boundaries

    ØUsing multiple IP routing protocols can be a result of migrating to a more advanced routing protocol, a multivendor environment, political boundaries, or device mismatch.

    ØRoute redistribution is possible between any two IP routing protocols.

    ØInternal routes are routes advertised with in the same protocol

    Ø External routes are routes which gets redistributed .

    49:11

    Configuring Redistribution into RIP

    Router(config)# router rip

    Router(config-router)# redistribute metric

    Note :Metric value has to be defined in the hops for the external routes redistributed in to RIP

    Configuring Redistribution into OSPF

    Router(config)# router ospf 5

    Router(config-router)# redistribute [metric ] [metric-type] [subnet]

    Configuring Redistribution into EIGRP

    Router(config)# router eigrp 10

    Router(config-router)# redistribute metric μs>

    Routing Metrics

      ·A seed metric must be defined when redistributing routes between routing protocols with unalike metrics.

      ·Some default seed metrics need to be changed to allow redistribution to take affect.

    Default seed metrics:

    EIGRP: Infinity (no routes enter the table)

    IS-IS: 0

    OSPF: 20 (type 2); BGP-learned routes are given 1 (type 2)

    BGP: MED is given the IGP metric value

    Section 7: Advance OSPF
    34:24

    OSPF Summarization

    Benefit Of Route Summarization

    •Minimizes number of routing table entries

    •Localizes the impact of a topology change

    •Reduces LSA 3 and 5 flooding and saves CPU resources



    Note : IN OSPF summarization can be done only on ABR or ASBR

    • If ospf routes need to be summarized can be done on ABR ( ex : 11.0.0.0 networks )

    If external routes to be summarized can be done on ASBR( ex : 14.0.0.0 networks

    40:39

    OSPF Virtual Link

      ·Virtual links are used to connect a discontiguous area to area 0

      ·A logical connection is built between routers

      ·Virtual links are recommended for backup or temporary connections

    Configuring Virtual Links :

    Router(config)#router ospf

    Router(config-router)#areavirtual-link

    26:15

    OSPF NETWORK TYPES


    Adjacency Behavior for a Broadcast Multi Access networks

      ·Generally these are, LAN technologies like Ethernet and Token Ring.

      ·DR and BDR selection are required.

      ·OSPF detects this type of link automatically.

      ·All neighbor routers form full adjacencies with the DR and BDR only.


    23:01

    Designated Router &Backup Designated Router

      ·The router having highest priority is DR

      ·The router with second-highest priority is BDR

      ·The default priority value is 1

      ·In the case of a tie, router with highest router ID is DR second highest router ID becomes the BDR

      ·If router priority is 0 it cannot become the DR or BDR

      ·Router which is not a DR or BDR is called as DROTHER

      ·DR & BDR election is not preemptive

    Router(config)#interface

    Router(config-if)#ip ospf priority number

    • The above interface configuration command assigns the OSPF priority to an interface.
    • Different interfaces on a router may be assigned different values.
    • The default priority is 1. The range is from 0 to 255.

    DR/BDR Elections Neighbors

    DR/BDR DROTHER Full

    DROTHER DR/BDR Full

    DROTHER DROTHER 2 Way

    Updates

    DROTHER DR/BDR 224.0.0.6

    DR DROTHER 224.0.0.5

    19:45

    Stub Areas

      ·External LSAs are stopped ( E1 and E2 routes)

      ·Default route is advertised into stub area by the ABR

      ·All routers in stub area must be configured as stub

    33:46

    Configuring all routers of Totally Stubby Area

    Router(config-router)#area stub

    Configuring Area Border Router of Totally Stubby AreaRouter

    (config-router)#area stubno-summary

    16:20
  • NSSA breaks stub area rules.
  • ASBR (R1) is allowed in NSSA.
  • Special LSA type 7 defined, sent by ASBR.
  • ABR (R2) converts LSA type 7 to LSA type 5.
  • ABR sends default route into NSSA instead of external routes from other ASBRs.
  • NSSA is an RFC addendum.
  • LAB: NSSA & Totally NSSA
    39:45
    OSPF LSA Types
    16:31
    Section 8: IPV6
    08:49

    Features of IPv6

      Larger Address Space

      Aggregation-based address hierarchy

      Efficient backbone routing

      Efficient and Extensible IP datagram

      Stateless Address Autoconfiguration

      Security (IPsec mandatory)

      Mobility

    06:36

    Assigning the IPV6 address

      1)Static

      2)Autoconfiguration

      a.Statefull ( via DHCP)

      b.Stateless ( device gets IP IPv6 add by including the MAC add )

    17:13

    IPV6 Address Types:

    UNICAST

    1) Global unicast

    ·like public IP ( routable ) , 2000:: and 2001::

    2) site local ( unique local)

      · like private ip ( routable)

      ·any address whichever starts with FC or FD in the first two numbers

    3) link local

      odefault IPV6 address on every ipv6 enabled interface

      o( non routable ) FE80::

    10:47

    TASK

    ·Configure basic Ipv6 Addresses as per the diagram

    Router(config)#hostname R-1

    R-1(config)#interface fastEthernet 0/0

    R-1(config-if)#ipv6 address fc00:11:11:11::1/64

    R-1(config-if)#no shutdown

    R-1(config-if)#exit

    R-1(config)#interface s1/0

    R-1(config-if)#ipv6 address 2001:12:12:12::1/64

    R-1(config-if)#no shutdown

    R-1(config-if)#end

    IPV6 address Stateless Autoconfiguration
    11:08
    IPV6 address Stateless Auto configuration LAB
    06:24
    13:22

    STATIC & DEFAULT ROTUING

    IPv6 support static and default routing and the working principle ( when to use and how it works is same what we learned in IPV4 routing )

      ·Syntax for writing static and default routing is similar in IPV6 when compared with IPV4

      ·As in IPv4, IPv6 has 2 families of routing protocols: IGP and EGP, and still uses the longest-prefix match routing algorithm

    11:56

    RIPng

      ·Same as IPv4:

      ·Distance-vector, 15-hop radius, split-horizon, poison reverse, and so on Based on RIPv2

      ·Updated features for IPv6:

      oUses IPv6 for transport

      oIPv6 prefix, next-hop IPv6 address

      oUses the multicast group FF02::9 for RIP updates

      oUpdates are sent on UDP port 521

    13:43

    OSPFv3

      ·Based on OSPFv2, with enhancements

      oDistributes IPv6 prefixes

      oRuns directly over IPv6

      oShips in the night with OSPFv2

      ·Adds IPv6-specific attributes:

      o128-bit addresses

      oLink-local address

      oMultiple addresses and instances per interface

      oAuthentication (now uses IPsec)

      oOSPFv3 runs over a link, rather than a subnet

    14:57

    EIGRP FOR IPv6

      ·Same EIGRP used with IPv4

      ·Best of distance vector and link state (advanced distance vector)

      ·Multiprotocol EIGRP has a protocol-dependent module for IPv4, IPX, AppleTalk, and now IPv6

      ·Easy to configure and fast convergence

    Section 9: Route Filtering Methods
    10:16

    Why do we need Route Filtering Methods

    }You might need to control exactly which routes are advertised or redistributed, or which paths are chosen.

    }Advertise only some specific Routes to Neighbor

    }Redistribute Specific Routes

    }Path Manipulation of some specific Routes

    }Changing Metric and Metric-type for specific routes

    }Changing The Administrative Distance for Specific Routes

    }With BGP

    Controlling routes to be advertised to ISP

    Control routes to get in to routing table

    }Policy Based Routing

    ways to control routing updates

    }Cisco IOS provides several ways to control routing updates:

    Passive Interface

    Distribute Lists

    Prefix Lists

    Route Maps

    12:52

    PASSIVE INTERFACE

    Passive-interface command is used in all routing protocols to disable sending updates out from a specific interface. However the command behavior varies from o­ne protocol to another.

    Passive Interface in RIPv2

    ·In RIP this command will disable sending multicast updates via a specific interface but will allow listening to incoming updates from other RIP speaking neighbors.

    ·This simply means that the router will still be able to receive updates o­n that passive interface and use them in the routing table.

    14:52

    Router(config)#router EIGRP 100

    Router(config-router)#passive-interface s1/0



    Router(config)#router OSPF 1

    Router(config-router)#passive-interface s1/0

    08:42

    Using Distribution lists

      ·A distribute-list is used to control routing updates either

      ocoming TO your router

      oor leaving FROM your router.

      ·Distribute-lists work on a variety of different IOS routing protocols.

      ·One of the easiest way

      ·Use an access list (or route map Or Prefix-list ) to permit or deny routes.

      ·Can be applied to transmitted, received, or redistributed routing updates.

    Configuring Distribute-list

    Router(config-router)# distribute-list

    13:40

    Configuring Distribute-list

    Router(config-router)# distribute-list

    09:52

    Using IP Prefix-list

    }The IOS IP prefix-list another tool for matching routes.

    }match two components of an IP route:

    The route prefix (the subnet number)

    The prefix length (the subnet mask)

    }The command then sets either a deny or permit action for each matched prefix/length.

    }Prefix lists work very similarly to access lists;

    }a prefix list contains one or more ordered entries which are processed sequentially.

      }The evaluatioqn of a prefix against a prefix list ends as soon as a match is found.

      }To create a prefix list or add a prefix-list entry, use the ip prefix-list command in global configuration mode. To delete a prefix-list entry, use the no form of this command.

      ip prefix-list list-name | list-number [seq number] {deny network/length | permit network/length}[ge length] [le length]

    30:27

    ip prefix-list list-name | list-number [seq number] {deny network/length | permit network/length}[ge length] [le length]

    08:27

    Route-maps

    }Route maps are similar to a scripting language for these reasons:

    }They work like a more sophisticated access list.

    }They offer top-down processing.

    }Once there is a match, leave the route map.

    }Lines are sequence-numbered for easier editing

    }Insertion of lines ,Deletion of lines

    }Route maps are named rather than numbered for easier documentation.

    }Match criteria and set criteria can be used, similar to the “if, then” logic in a scripting language.

    }The common uses of route maps are as follows:

    Redistribution route filtering: a more sophisticated alternative to distribute lists

    Policy-based routing: the ability to determine routing policy based on criteria other than the destination network

    BGP policy implementation: the primary tool for defining BGP routing policies

    22:29

    Configure Route Map

    Router(config)# Route-map permit/deny

    Defining the condition to Match

    Router(config-route-map)#match

    Defining the condition to Set

    Router(config-route-map)#set

    match conditions used in redistribution:

    match interface

    match ip address [ACL]

    match ip next-hop

    match ip route-source

    match metric

    match route-type

    set operations used in redistribution:

    set level {level-1 | level-2 | level-1-2 | stub-area | backbone} (OSPF/IS-IS)

    set metric

    set metric-type {internal | external | type-1 | type-2}

    LAB: Route filtering using Routemaps
    11:09
    11:00

    POLICY -BASED ROUTING

    ØIt is used for implementing policy that cause the packet to take a different direction

    ØPBR allows source based routing

    ØRouting table is destination base

    ØPBR can be used for making type of service tag

    ADVANTAGES

    ØDifferent users can go from different directions

    ØLoad sharing

    ØPBR will be implemented on the incoming direction of the source interface

    ØIf the packet is match in the route map and it is permit it will be send according to the policy

    ØIf the packet is match in the route map and route map deny packet will be forwarded according to normal routing table

    LAB : Source based Policy Based Routing
    17:19
    LAB : Destination based Policy Based Routing
    12:38
    LAB : Services Specific Policy Based Routing
    09:19
    LAB : Policy Based Routing for Packet size
    07:40
    Section 10: BGP
    24:42

    Introduction to BGP

      ·BGP is the only routing protocol in widespread use which facilitates inter-domain routing (between autonomous systems).

      ·BGP is path-vector; routes are tracked in terms of which autonomous systems they pass through.

      ·BGP attributes allow granularity in path selection.

    When to use BGP

    BGP is more appropriate if one of the following conditions exist

      §A.S. working as transit A.S. (Ex. ISP)

      §A.S. connected to multiple A.S.

      §Data traffic path entering or leaving A.S. need to manipulated

    When not to use BGP

    BGP is not recommended if one or more following condition exist

      §If it is Single-home A.S

      §Lack of recourses like memory and less processing power in routers

      §Low bandwidth link between A.S

      §Limited understanding about BGP route filtering and path selection processes

    17:37

    Types of ISP Connections


    Single Homed

    Dual-homed site

    Multihoming

    Dual Multihomed

    10:52

    BGP Neighbors

      ·BGP neighbors are routers forming TCP connection for exchanging BGP updates. Also called as BGP Peers or BGP Speakers.

      ·Two type of BGP neighbor relationship.

      §IBGP

      §EBGP

    27:18

    ·Configuration parameters such as neighbor IP addresses and their AS number, and which networks you will advertise via BGP

    Router(config)# router bgp

    Router(config-router)# network [mask ]

    Router(config-router)# neighbor remote-as

    35:08
  • Update-source command allows the BGP process to use the IP address of a specified interface as the source IP address of all BGP updates to that neighbor.
  • A loopback interface is usually used, because it will be available as long as the router is operational.
  • The IP address used in the neighbor command on the other router will be the destination IP address of all BGP updates and should be the loopback interface of this router.
  • The neighbor update-source command is normally used only with IBGP neighbors.
  • The address of an EBGP neighbor must be directly connected by default; the loopback of an EBGP neighbor is not directly connected.
  • 07:37

    Configuring BGP Authentication on Cisco IOS:

      ·Border Gateway Protocol (BGP) supports authentication mechanism using Message Digest 5 (MD5) algorithm.

      ·When authentication is enabled, any Transmission Control Protocol (TCP) segment belonging to BGP exchanged between the peers is verified and accepted only if authentication is successful.

      ·For authentication to be successful, both the peers must be configured with the same password.

      ·If authentication fails, the BGP neighbor relationship is not be established.

      Router(config-router)#neighbor {ip-address | peer-group-name} <password string>

    11:44

    Peer groups

      ·Peer groups are defined to efficiently apply same policies to multiple neighbors:

      ·Peer groups are useful when many neighbors have the same outbound policies.

      ·Members can have a different inbound policy.

      ·Updates are generated once per peer group.

      ·Configuration is simplified.

    Router(config-router)# neighbor peer-group

    This command creates a peer group.

    Router(config-router)# neighbor < peer-group peer-group-name>

    19:44

    In order to get the routes to be learned we have two Solutions:

      1.Full mesh neighborship ( which the requirement says not to use here )

      2.Route reflector

    To Configure Route-reflector

      ·All Clients should establish neigbbor with only servers

      ·Clients will not establish neigbor with any other clinet

      ·In case if you have 2 servers ( server establish neigbbor with other servers and clients )

    LAB : Basic EBGP Configuration
    07:58
    17:57

    When EBGP ---sends an update to another EBGP neighbor -------------changes the next hop

    When IBGP ---sends an update to another IBGP neighbor ------------- the next hop remains same (not change)

    16:55

    BGP neighbor ebgp-multihop Command

      ·This command increases the default of one hop for EBGP peers.

      ·It allows routes to the EBGP loopback address (which will have a hop count greater than 1).

      ·Ebgp-multihop tells to neighbor that the 12.0.0.1 is not directly connected and it is multiple hops away

      ·Increases the default TTL value from 1 to 255

    11:43

    Synchronization rule:

      ·Do not use or advertise to an external neighbor a route learned by IBGP until a matching route has been learned from an IGP

      ·Ensures consistency of information throughout the AS.

      ·Safe to have it off only if all routers in the transit path in the AS are running full-mesh IBGP;

      ·off by default in Cisco IOS software release 12.2(8)T and later

      ·BGP synchronization is often disabled for autonomous systems which do not act as a transit AS.

      ·Safe to have it off only if all routers in the transit path in the AS are running full-mesh IBGP; off by default in Cisco IOS software release 12.2(8)T and later

    Router (config-router)# no synchronization

    ·The above command Disables BGP synchronization so that a router will advertise routes in BGP without learning them in an IGP

    Router (config-router)# synchronization

  • The Above Command enables BGP synchronization so that a router will not advertise routes in BGP until it learns them in an IGP
  • 10:09

    BGP ATTRIBUTES

    BGP chooses a route to a network based on the attributes of its path. Four categories of attributes exist as follows:

      ·Well-known mandatory:

      oMust be recognized by all BGP routers, present in all BGP updates, and passed on to other BGP routers. For example, AS path, origin, and next hop.

      ·Well-known discretionary:

      oMust be recognized by all BGP routers and passed on to other BGP routers but need not be present in an update, for example, local preference.

      ·Optional transitive:

      oMight or might not be recognized by a BGP router but is passed on to other BGP routers.

      oIf not recognized, it is marked as partial, for example, aggregator, community.

      ·Optional non-transitive:

      oIf the BGP process does not recognize the attribute then it can ignore the update and not advertise the path to its peers

      ofor example, Multi-Exit Discriminator (MED), originator ID.

    18:32

    AS Path

      ·AS Path is Well known, mandatory attribute

      ·List of AS through which updates has traversed.

      ·Path with shortest AS path list is more desirable.

    Next Hop

      ·The next-hop attribute is well-known, mandatory.

      ·BGP is AS by AS routing Protocol

      ·Next hop ≠ next router

      ·Next hop = IP to reach next AS

    The IP address of the next AS to reach a given network:

    • Router A advertises network 172.16.0.0 to router B in EBGP, with a next hop of 10.10.10.3.
    • Router B advertises 172.16.0.0 in IBGP to router C, keeping 10.10.10.3 as the next-hop address.

    ORIGIN

      ·Origin informs all AS in Internetwork how network got introduced into BGP.

      oIGP (i) advertised in BGP using network command

      oEGP (e) Redistributed from EGP

      oIncomplete (?) Redistributed in to BGP from IGP or static

      ·The origin attribute is well-known, mandatory, and transitive.

      ·“I” is better then “E” and “e” is better then “?”

    20:51

    TASK:

    Configure R1 to prefer exit path via R4 to reach all the Networks.

    By default R1 prefer via R2 (1.1.1.2) to reach 20.0.0.0/30.0.0.0 network as it has less number of AS path.

    12:40

    WEIGHT

      ·Weight is Cisco’s attribute.

      ·Tells how to exit the AS

      ·Path with the highest weight is more desirable.

      ·Local to the router ( not advertise to the other routers in the AS )

      ·Weight is partial attribute.

      ·Default weight = 0 for learned routes, 32,768 for locally injected routes)

    LOCAL PREFERENCE

      ·Local preference defines how data traffic should exit from an AS.

      ·Path with highest preference value is more desirable.

      ·It is advertised only to IBGP neighbor within an AS.

      ·Default value is 100

      ·Local preference is well known, discretionary attribute.

    17:06

    TASK:

    ·Make sure that only 12.0.0.0 and 12.0.1.0 both networks should prefer via R4 where as the remaining should use the default route via R2 :

    R1(config)#access-list 12 permit 12.0.0.0 0.0.0.255

    R1(config)# access-list 12 permit 12.0.1.0 0.0.0.255

    R1(config)# route-map WEIGHT permit 10

    R1(config-route-map)# match ip address 12

    R1(config-route-map)# set weight 5000

    R1(config-route-map)# exit

    R1(config)# route-map WEIGHT permit 20

    R1(config-route-map)#end

    R1(config)#router bgp 500

    R1(config-router)#neighbor 4.4.4.1 route-map ?

    WORD Name of route map

    R1(config-router)#neighbor 4.4.4.1 route-map WEIGHT ?

    in Apply map to incoming routes

    out Apply map to outbound routes

    R1(config-router)#neighbor 4.4.4.1 route-map WEIGHT in

    R1(config-router)#end

    R1#clear ip bgp *

    07:16

    IN Bound

    Out Bound

    ·In bound Route-map Changes the local Router Path selection process.

    ·outbound Route-maps influence some other Routers Decision

    ·In Bound Route-maps apply changes to BGP updates recived from that specific Neighbor

    ·Out Bound Route-maps apply changes routes advertised to that specific Neighbor

    ·Applying inbound influence outbound Traffic

      ·Applying outbound influence inbound Traffic

    18:37

    TASK:

      · All the routes going from AS 600 to reach as -700 ( 40.0.0.0 ) by default prefers out via R3

      ·Make sure that R2 and R3 (all the routers in the as 600 should prefer use path via R2 /R1/R4 using local preference.)


    14:41

    TASK:

      ·Configure AS 600 such that only routes ( 14.0.0.0 and 14.0.1.0 ) both networks prefer via R2 to exit the AS

      ·All the remaining networks should use the default exit ( via R3)

    R2

    R2(config)#access-list 14 permit 14.0.0.0 0.0.0.255

    R2(config)# access-list 14 permit 14.0.1.0 0.0.0.255

    R2(config)# route-map LOCAL permit 10

    R2(config-route-map)# match ip add 14

    R2(config-route-map)# set local-preference 2000

    R2(config-route-map)# exit

    R2(config)# route-mapLOCAL permit 20

    R2(config-route-map)# exit

    R2(config)# router bgp 600

    R2(config-router)# neighbor 1.1.1.1 route-map LOCAL in

    R2(config-router)#end

    16:23

    Route Selection Decision Process

    Consider only (synchronized) routes with no AS loops and a valid next hop, and then:

    1. Prefer highest weight (local to router).
    2. Prefer highest local preference (global within AS).
    3. Prefer route originated by the local router (next hop = 0.0.0.0).
    4. Prefer shortest AS path.
    5. Prefer lowest origin code (IGP < EGP < incomplete) i > E > ? .
    6. Prefer lowest MED (exchanged between autonomous systems).
    7. Neighbor Type (Prefer eBGP over iBGP)
    8. IGP metric to NEXT_HOP (Smaller value preferred)
    9. Prefer oldest route for EBGP paths.
    10. Prefer the path with the lowest neighbor BGP router ID.
    11. Prefer the path with the lowest neighbor IP address.

    Students Who Viewed This Course Also Viewed

    • Loading
    • Loading
    • Loading

    Instructor Biography

    Senior Technical Instructor/Network Consultant

    Sikandar Shaik, a dual CCIE (RS/SP# 35012), is a highly experienced and extremely driven senior technical instructor and network consultant. He has been training networking courses for more than 10 years, teaching on a wide range of topics including Routing and Switching, Service Provider and Security (CCNA to CCIE). In addition, he has been developing and updating the content for these courses. He has assisted many engineers in passing out the lab examinations and securing certifications.

    Sikandar Shaik is highly skilled at designing, planning, coordinating, maintaining, troubleshooting and implementing changes to various aspects of multi-scaled, multi-platform, multi-protocol complex networks as well as course development and instruction for a technical workforce in a varied networking environment. His experience includes responsibilities ranging from operating and maintaining PC's and peripherals to network control programs for multi-faceted data communication networks in LAN, MAN and WAN environments.

    Sikandar Shaik has delivered instructor led trainings in several states in India as well as in abroad in countries like China, Kenya and UAE. He has also worked as a Freelance Cisco Certified Instructor globally for Corporate Major Clients.

    Ready to start learning?
    Start Learning Now